Changes between Version 48 and Version 49 of public/FreqAsked


Ignore:
Timestamp:
2017-05-12T13:01:58+01:00 (7 months ago)
Author:
svn_jvogl
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • public/FreqAsked

    v48 v49  
    221221This is a bug of an older version of CMake. Please grab the latest CMake version from http://www.cmake.org/download, uninstall the old CMake programs and re-configure with the new one. 
    222222 
     223=== Changing used compiler (with cmake) === 
     224 
     225Create a build folder. Inside this folder, call {{{CC=[compiler] CXX=[compiler++] cmake [PathToGismo]}}} where {{{[compiler]}}} and {{{[compiler++]}}} are your preferred compilers executables and {{{[PathToGismo]}}} is the (relative) path to your gismo-subversion folder. It could also be done by entering the cmake menu with ccmake . and going into the advanced mode, but it's preferred to do it with a new folder instead. 
     226 
     227GCC and clang are in the folder {{{/usr/bin}}}.  
     228The Intel Compilers - if you suppossed to use it - are under {{{/opt/intel/compilers_and_libraries_xxxx.x.xxx/linux/bin/intel64/}}}. You may need to run the script for the paths before a build: {{{source /opt/intel/compilers_and_libraries_xxxx.x.xxx/linux/bin/compilervars.sh intel64}}}. 
     229If the Intel Compiler doesn't work, it could be a problem with the license file - found under {{{/opt/intel/licenses/network.lic}}}. 
     230 
     231To change from C++ 11 Standard to 98 or 14, type {{{cmake . -DCMAKE_CXX_STANDARD=xx}}} where {{{xx}}} is 98, 11 or 14. 
     232 
    223233==== Your question ? ==== 
    224234